User Tools

Site Tools


zh_cn:player:tutorials:install_multimc:windows

安装Fabric — MultiMC(Windows)

MultiMC 是开源免费的 Minecraft启动器,允许你拥有多个互相分开的 Minecraft 实例(每个都有各自的模组、材质包、存档等)并通过一个简单而强大的界面帮助你管理。

第一步:安装MultiMC

此处下载和安装MultiMC。Windows系统可以解压到C:\MultiMC或其他文件夹。<!– If you are on Windows, you can extract and move the MultiMC folder inside the zip you downloaded to the root folder of your C: drive, so you end up with MultiMC installed on C:\MultiMC, or use any other location to unzip the MultiMC folder. –>

Also you may need to install Java: Install/Verify Java (Windows)

视频教程

看看 Kennas 的视频:here 或者点击下方的图片:

YouTube


第二步:在MultiMC 0.6.6以上的版本创建新的Fabric Minecraft实例

打开 MultiMC 并使用安装步骤配置。点击MultiMC工具栏中的添加实例按钮:

为实例输入名称并选择Minecraft版本,然后点击确定

选择了实例之后,点击右边的编辑实例

点击安装Fabric

选择Fabric加载器版本,点击OK

检查实例的Minecraft版本的中介映射和Fabric加载器,点击关闭

运行刚刚创建的实例,MultiMC会下载合适的Minecraft以及库文件并创建实例子文件夹。

检查Minecraft/Fabric启动,一切完美!

现在关闭Minecraft实例。


第三步:安装Fabric API

刚刚创建的实例包含Fabric模组加载器,现在你需要安装Fabric API以使用大多数Fabric模组。

Fabric API是绝大多数通用钩子的核心库,以及使用Fabric工具链的模组的互相兼容方法。

如果不懂这是什么意思,可以这样理解:Fabric API像绝大多数其他模组一样,是由Fabric加载器加载的模组,且绝大多数其他的Fabric模组都依赖它,所以Fabric API可以说是需要最先安装的模组。

可以在https://www.curseforge.com/minecraft/mc-mods/fabric-api/files/all下载对应版本的最新的Fabric API。

注意Curse不一定实时更新到最新的Minecraft版本,所以“游戏版本”中的版本不一定是文件的实际版本。各文件用于哪个游戏版本,请以文件名为准。

比如,如果你的实例是 Minecraft 1.14.2,则正确的Fabric API文件应该是“[1.14.2] Fabric API 0.3.0 build 175”(或者更加新的版本)。

将jar文件下载到实例的mods文件夹。

比如如果 MultiMC 位于 “C:\MultiMC”则你的实例名称可能是“FABRIC-1.14.2”,然后实例的模组文件夹就应该是“C:\MultiMC\instances\FABRIC-1.14.2\.minecraft\mods”。

路径 C:\MultiMCC:\MultiMC\instances\FABRIC-1.14.2\.minecraft\mods 只是举例,实际路径可能不同:

你解压MultiMC的地方\MultiMC\instances\实例名称\.minecraft\mods

运行Minecraft实例,确保一切如期运行。


第四步:安装Fabric模组

如需查看已安装的模组列表并修改模组设置(如有),你需要安装Mod Menu (Fabric)模组。Mod Menu会给Minecraft主屏幕添加一个按钮:

点击此按钮打开已安装的Fabric模组列表。右上角的按钮可用于修改模组设置。

可在https://www.curseforge.com/minecraft/mc-mods/modmenu安装Mod Menu模组,点击“files”下载适合实例版本的模组,将文件下载/复制到mods文件夹。

可以在here查看模组列表。将模组下载/复制到mods文件夹。同样地,检查文件名中的Minecraft版本,不要仅以“游戏版本”栏中的版本为准。一般来说旧版本的模组可较好地兼容较新版本的Minecraft(Fabric),如1.14和1.14.1的模组应该能够较好地兼容1.14.2,你可以自行尝试。

注意一些模组依赖其他模组才能运作。下载模组文件时,点击文件名称,到页面底部检查是否有“Related Projects”,看看里面是否列举了依赖项(dependencies)。你需要安装此模组依赖的模组,并且可以选择安装此模组的“可选依赖”模组。


第五步:尽情地玩吧!

zh_cn/player/tutorials/install_multimc/windows.txt · Last modified: 2021/07/04 08:19 by solidblock