User Tools

Site Tools


zh_cn:faq:user

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
zh_cn:faq:user [2020/01/08 12:02]
lightcolour [Fabric可以和Sponge一起跑吗?]
zh_cn:faq:user [2020/11/04 03:34] (current)
solidblock translate
Line 1: Line 1:
-====== ​问的问题 (用户) ======+====== 常问题 (用户) ======
  
 这个是一个精简版的常见问题。关于技术类问题请移步[[zh_cn:​faq:​expert|专家页面]]. 这个是一个精简版的常见问题。关于技术类问题请移步[[zh_cn:​faq:​expert|专家页面]].
Line 7: Line 7:
 ==== Fabric支持哪些Minecraft版本? ==== ==== Fabric支持哪些Minecraft版本? ====
  
-18w43a快照版以及以上。(1.14正式版及以上+18w43a快照版以及以上1.14正式版及以上
  
-Fabric在微调后可以在旧Minecraft版本上运行。详见专家页面。+Fabric在微调后可以在旧Minecraft版本上运行。详见专家FAQ页面。
  
 ==== 有什么Fabric整合包吗? ==== ==== 有什么Fabric整合包吗? ====
  
-A few modpacks are currently being distributed via MultiMC ​exports, such as [[https://​github.com/​AllOfFabric/​AOF/​releases|All of Fabric]]Don't bother with the Launchpacks - they are generally "proof of concept"​ and not intended for production gameplay.+一些mod包正在通过MultiMC的导出来传播,比如[[https://​github.com/​AllOfFabric/​AOF/​releases|All of Fabric]]Don't bother with the Launchpacks - they are generally "proof of concept"​ and not intended for production gameplay.
  
 ==== 什么启动器支持Fabric(及其整合包)? ==== ==== 什么启动器支持Fabric(及其整合包)? ====
  
-As of 30th June, the following launchers are available for this:+截至2020年5月9日,可用的启动器有:
  
-  * MultiMC - a guide is available ​[[tutorial:​install_with_multimc|here]]; newest development builds also include an "​Install ​Fabric" button. +  * MultiMC - [[zh_cnLtutorial:​install_with_multimc|这里]]有一份指导;最新测试版本也有“安装Fabric”按钮。 
-  * Vanilla ​an installer is available on Fabric's download page.+  * 原版 ​- Fabric的下载页面有安装器。 
 +  * Twitch(非官方) - 通过将[[https://​www.curseforge.com/​minecraft/​mc-mods/​jumploader|Jumploader]]模组加入你的模组包。 
 +  * GDLauncher - 支持Fabric,只要选择“Fabric”然后创建实例时选择版本。 
 +  * ATLauncher - 可以在Fabric的下载页面下载。 
 +  * HMCL - 支持Fabric下载安装,可以从镜像网站下载。
  
-**Please keep in mind** that Fabric API is a separate component and must be downloaded separately ​you can find it [[https://​www.curseforge.com/​minecraft/​mc-mods/​fabric-api|here]].+**务必记住**Fabric API是单独的组件,需要单独下载 ​你可以在[[https://​www.curseforge.com/​minecraft/​mc-mods/​fabric-api|这里]]下载(无需科学方法,但是可能需要完成人机验证)。
  
-We recommend ​MultiMC ​due to its superior user experience for modded environments. ​+推荐MultiMC因为对加了模组的环境的丰富的用户经验。
  
-==== 什么启动器支持发Fabric整合包? ====+==== 我可以用什么启动器分整合包? ====
  
-As of 30th June, the following launchers are available for this:+截至2019年6月30日,可以用以下启动器:
  
   * MCUpdater - [[tutorial:​mcupdater_modpacks|guide]]   * MCUpdater - [[tutorial:​mcupdater_modpacks|guide]]
Line 41: Line 45:
 ==== Fabric可以和Bukkit/​Spigot/​Paper一起运行吗? ==== ==== Fabric可以和Bukkit/​Spigot/​Paper一起运行吗? ====
  
-现在不行。 这种情况可能会在年底改变,但不太可能得到正式支持。+现在不行。这种情况可能会在年底改变,但不太可能得到正式支持。 
 ==== Fabric可以和Forge一起运行吗? ==== ==== Fabric可以和Forge一起运行吗? ====
  
Line 53: Line 58:
  
 没有正式版。 但是,有非官方的mod来促进在Fabric上启动适用于1.14+的OptiFine。 但您的里程可能会有所不同。 没有正式版。 但是,有非官方的mod来促进在Fabric上启动适用于1.14+的OptiFine。 但您的里程可能会有所不同。
-==== Oh no! I've tried enabling shaders on OptiFine and my world looks all weird! ==== 
  
-Fabric's rendering patches, while as minimally invasive as possible, make some assumptions about the data format used internally by the vanilla rendering systemShaders break this assumption, so things go awry. Workarounds do exist and are implemented by the most recent versions of said unofficial mods.+将使用OptiFine的作为一种可选项,因为非官方模组如OptiFabric可能与你的模组不兼容。 
 + 
 +[[https://​gist.github.com/​LambdAurora/​1f6a4a99af374ce500f250c6b42e8754|OptiFine alternatives on Fabric]] 
 + 
 +[[https://​gist.github.com/​modmuss50/​deff1658c4550ca8b16cb5d40ceaa468|The future of Optifabric and recommended alternatives]] 
 + 
 +==== 糟糕!我尝试通过OptiFine开光影,结果世界变奇怪了! ==== 
 + 
 +Fabric的渲染补丁是尽可能不修改的,可推测和原版渲染系统内部使用的数据格式的有关。光影“破坏”了这种推测,所以变奇怪了。Workarounds do exist and are implemented by the most recent versions of said unofficial mods.
  
-**DO NOT** downgrade ​Fabric API as a workaround for this. It's a bad idea.+**不要**Fabric API降级来解决这个问题。这是个馊主意。
  
 ==== Fabric可以和Sponge一起运行吗? ==== ==== Fabric可以和Sponge一起运行吗? ====
  
 现在不行。 Sponge尚未为运行Fabric的Minecraft版本1.14提供现成的API或有效的实现。 现在不行。 Sponge尚未为运行Fabric的Minecraft版本1.14提供现成的API或有效的实现。
zh_cn/faq/user.1578484977.txt.gz · Last modified: 2020/01/08 12:02 by lightcolour