User Tools

Site Tools


zh_cn:faq:user

常见问题 (用户)

这个是一个精简版的常见问题。关于技术类问题请移步专家页面.

通用

Fabric支持哪些Minecraft版本?

18w43a快照版以及以上、1.14正式版及以上。

Fabric在微调后可以在旧Minecraft版本上运行。详见专家FAQ页面。

有什么Fabric整合包吗?

一些mod包正在通过MultiMC的导出来传播,比如All of Fabric。Don't bother with the Launchpacks - they are generally “proof of concept” and not intended for production gameplay.

什么启动器支持Fabric(及其整合包)?

截至2020年5月9日,可用的启动器有:

  • MultiMC - 这里有一份指导;最新测试版本也有“安装Fabric”按钮。
  • 原版 - Fabric的下载页面有安装器。
  • Twitch(非官方) - 通过将Jumploader模组加入你的模组包。
  • GDLauncher - 支持Fabric,只要选择“Fabric”然后创建实例时选择版本。
  • ATLauncher - 可以在Fabric的下载页面下载。
  • HMCL - 支持Fabric下载安装,可以从镜像网站下载。

务必记住Fabric API是单独的组件,需要单独下载 - 你可以在这里下载(无需科学方法,但是可能需要完成人机验证)。

推荐MultiMC因为对加了模组的环境的丰富的用户经验。

我可以用什么启动器分享整合包?

截至2019年6月30日,可以用以下启动器:

  • MCUpdater - guide
  • Technic (Solder) - guide
  • ATLauncher - guide
  • MultiMC/Vanilla - you can always export a modpack or use a ZIP file!

Please note that we have no information or ETA regarding support by the Twitch Launcher.

兼容性

Fabric可以和Bukkit/Spigot/Paper一起运行吗?

现在不行。这种情况可能会在年底改变,但不太可能得到正式支持。

Fabric可以和Forge一起运行吗?

*在当前的Minecraft版本上,Fabric当前无法在Forge之上运行。

  • 从理论上讲,有可能创建一种方法,也就是说,实现这一目标没有已知的主要技术障碍。
  • 在这方面进行了一些实验和讨论(截至6月30日),但最终用户或mod开发人员无法使用。

开发团队不认为Forge互操作是一个高优先级的目标,因为我们在有限的时间内致力于该项目的重点是为Fabric社区及其开发人员和用户提供支持。

Fabric可以和OptiFine一起运行吗?

没有正式版。 但是,有非官方的mod来促进在Fabric上启动适用于1.14+的OptiFine。 但您的里程可能会有所不同。

将使用OptiFine的作为一种可选项,因为非官方模组如OptiFabric可能与你的模组不兼容。

OptiFine alternatives on Fabric

The future of Optifabric and recommended alternatives

糟糕!我尝试通过OptiFine开光影,结果世界变奇怪了!

Fabric的渲染补丁是尽可能不修改的,可推测和原版渲染系统内部使用的数据格式的有关。光影“破坏”了这种推测,所以变奇怪了。Workarounds do exist and are implemented by the most recent versions of said unofficial mods.

不要将Fabric API降级来解决这个问题。这是个馊主意。

Fabric可以和Sponge一起运行吗?

现在不行。 Sponge尚未为运行Fabric的Minecraft版本1.14提供现成的API或有效的实现。

zh_cn/faq/user.txt · Last modified: 2020/11/04 03:34 by solidblock